0

I am trying to clip a 6 band Micasense Altum image which is in Uint16 format, with 5 multispectral bands and a thermal band which is lower resolution. The image was aligned using the micasense alignment procedure. The image and shapefile don't have a CRS, but align perfectly in QGIS . The Clip Raster by Mask Layer tool results in the correct area being clipped, but the output is entirely black.

I have tried various compressions (LZW, JPEG, NONE) and deflation options to no avail, i.e as per the discussion here: Creating compressed GeoTIFF with QGIS Clipper tool?

My additional command line parameters include:

-to SRC_METHOD=NO_GEOTRANSFORM -crop_to_cutline

Here is a link to the dataset and below is a screenshot of the issue.

Screenshot

2
  • What do you see in Layer Properties - Symbology - Contrast enhancement?
    – user30184
    Aug 4 at 13:09
  • Contrast enhancement is set to 'Stretch to MinMax' Aug 4 at 13:13

1 Answer 1

1

Something does not match in how GDAL and QGIS are dealing with the non-georeferenced images. This is where GDAL is placing the image:

gdalinfo bgrnet.tiff
Driver: GTiff/GeoTIFF
Files: bgrnet.tiff
Size is 2031, 1497
Image Structure Metadata:
  INTERLEAVE=PIXEL
Corner Coordinates:
Upper Left  (    0.0,    0.0)
Lower Left  (    0.0, 1497.0)
Upper Right ( 2031.0,    0.0)
Lower Right ( 2031.0, 1497.0)
Center      ( 1015.5,  748.5)

This shows what QGIS is doing. Notice the negative Y coordinate at the lower left corner.

enter image description here

The polygon is perhaps digitized with QGIS and it intersect with the image in QGIS but because it also has negative Y coordinates GDAL/gdalwarp thinks that the polygon does not intersect with the image that all pixels in the positive Y range:

ogrinfo polygon.shp -al -so
...
Extent: (1056.422015, -645.642621) - (1284.138348, -65.263903)

The option -to SRC_METHOD=NO_GEOTRANSFORM probably tries to handle this case but it does not quite succeed and pixels are picked from outside of the image.

The easiest fix might be to attach some fake projection like EPSG:3857 to the image with gdal_edit https://gdal.org/programs/gdal_edit.html, open the now georeferenced image into QGIS and digitize the cropping polygon on top of the image.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.