1

I try to join data by its position. I have one layer with GPX data as points and another layer managing zones as polys. I wanna get the data from the poly where the corresponding point is within and join it to the point's data attribute table. For that i use Join Attributes by Location with the following settings.

enter image description here

Running this always results in a table that has all features of the point layer and the additional fields from the poly layer but the poly layer attributes are always null. The "joined count" always is 0. Even if i change the geometrict predicate, no result at all.

What I am doing wrong?

Every layer is in UTM and is correctly shown on my maps

6
  • If you try 'Intersect' what happens? It will behave almost the same as 'within' for points.
    – Cushen
    Aug 5 at 6:33
  • Unfortunately its the same result ... does it matter that the poly layer data comes from a WFS Server?
    – Jim Panse
    Aug 5 at 7:04
  • Its multi polygon layer
    – Jim Panse
    Aug 5 at 7:13
  • Have you tried storing the WFS data locally and then running the join?
    – Erik
    Aug 5 at 8:38
  • 1
    No i didn't, but i think it has something to do with that ... the attribute tables seems to stop on 20k entries for WFS server. Don't know the internal implementation but i could imagine that it just not "reaches" the dataset that would be interesting to join with my points, because its after the 20000 points somehow (even if they are displayed correctly, but on join they will call wfs again with limit 20k maybe) ... so i think i have to use a BBOX somehow to restrict it to my current map section (?)
    – Jim Panse
    Aug 5 at 8:54

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.