1

(not sure how to wrap the subject into a question! But...)

Here are some issues I've been having with the OSM plugin:

1) When I bring in the .OSM file, close QGIS, then reopen, I get a "Handle Bad Layers" dialogue...see image below:enter image description here

2) When I open QGIS with the OSM plugin enabled, it seems to cause a crash with Unity Desktop, that is, the menu bar at the top of Ubuntu goes blank, then seems to reload. Disabling the plugin and loading QGIS solves the issue.

Anyone else had this?

1

The OSM plugin only works as an importer. The data is stored in a temporary database.

If you have your data loaded, you better save them in another format, like shapefile or spatialite database, and delete the OSM layers.

That way you can be sure to reopen the project without problems.

Unfortunately, the style of the osm layers can not be copied to the shapefile/spatialite layers.

  • Andre: thank you. This is what I suspected was the problem... Does anyone see a fix for this any time soon? – DPSSpatial Dec 12 '12 at 19:58
  • 1
    I opened a ticket for this: hub.qgis.org/issues/6863. Please accept the answer so this question can be closed. – AndreJ Dec 12 '12 at 20:28
1

Adding this to the answer as came here getting same problem but for different reasons but the answer helped me find the solution. If you use the QuickOSM plugin to extract contract you will also get the 'Handle Bad Layers' error for the same reasons described above. As default QuickOSM saves imports to a temporary directory, there's an option on which directory to save to. To avoid error save to a named directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.