-2

I am loading a .las file into R using the lidR package (4.0.1) and it is showing to have 0 area and 0 point density.

enter image description here

When I try to plot it using plot(), it shows up as a single vertical line:

enter image description here

When I run las_check(), there is an issue with the scale factor, but when I tried to rescale using las_rescale() to 0.01 for all 3 factors, the same plotting and 0 area and 0 point density issue occurs and it said that all 15 million points were duplicated.

enter image description here

2
  • Your file may be corrupted but based on my experience it is more likely that XY are longitude/latitude in degrees and Z is elevation in meters. The CRS being empty I can't know but you can check the range of XY with range(las$X) and range(las$Y). The scale factors being 10-8 the long/lat scenario is highly probable.
    – JRR
    Aug 31 at 22:14
  • 1
    And please delete screenshots of text and replace by actual copy pasted text
    – JRR
    Aug 31 at 22:15

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.