1

I have spent quite a bit of time trying to figure this issue out; I was hoping someone on here could give some advice on what to do. I am having issues with terracing on my 3D model in Blender and I believe it's because I am not exporting the data correctly from QGIS. Here is an example of the terracing I am talking about:

enter image description here

For reference, I am following this tutorial on how to create a 3D relief map in Blender: https://somethingaboutmaps.wordpress.com/blender-relief-tutorial-getting-set-up/

So far, I have successfully acquired my DEM, reprojected it, clipped it, and now I am having issues on rescaling my DEM range to 0-65,535 and then saving it as a 16-Bit unsigned TIFF. As seen in step 6 and 7 within the link provided above.

To rescale my data so that it can be read as a 16-Bit TIFF from the current float32 that it's in, I have tried using raster calculator on my original clipped DEM ("clipped regular" in the picture). I used this as my formula: ("DEM"-lowestvalue)/(highestvalue-lowestvalue)*65535 as seen in the picture below. I made sure to use the exact values of the min and max within my DEM and I still cannot get the final raster to have the min value at 0...

enter image description here

When I open my new recalculated DEM, it has a min value of -0.0000000015 and max of 65535. I am curious if this is the portion of the process that is causing my DEM to terrace when uploading to blender.

So now I have a 32float DEM with a min of -0.0000000015 and max of 65535, and a No-Data value of -3.40282e+38 when I check my layer properties information. I feel as though this is not right, however, continuing on in the process.

I run the Translate (convert format) tool to change this DEM into a UInt16 data type so Blender can read the data properly. However, after running it, it changes my DEM values to a min of 2 and max of 62303. As seen in picture below:

enter image description here

Now, when I upload this DEM to Blender, I still am having issues with tiling and unsmooth textures as seen below.

enter image description here

I followed the final step (step 8) and brought the new 16 bit TIFF file into a photo editing app and save it out and did not have any luck.

I am lost as to what I am missing. I have tried quite a few things with the raster calculator to get my values set to 0 and 65535, but I am either having no-data values in my DEM or not getting values close to 0 and 65535.

I think the issue is that I cannot get my DEM into a 16-bit TIFF file with a min value of 0 and max of 65535; however, I am unsure.

5
  • What happens when you translate the original DEM to UInt16, instead of the rescaled DEM?
    – Stu Smith
    Sep 17, 2022 at 2:16
  • Also, I had great success following this tutorial. Not sure that it will solve your problem, but just in case... youtube.com/watch?v=QSAH_NBU8ko
    – Stu Smith
    Sep 17, 2022 at 2:17
  • I propose that you use the QGIS Identify tool to measure elevations, at a variety of locations (including the terraced areas) with both the source 32-bit and terraced 16-bit images enabled in the TOC. Studying the results may help you understand the differences between the layers, and how that might affect the terracing. Also, does the terracing occur everywhere across the 16-bit DEM? I have a hunch that it occurs only on low-angle areas, which would be an indication of the loss of fine detail when converting from 32-bit to 16-bit.
    – Stu Smith
    Sep 17, 2022 at 2:27
  • For comparing the Profile tool is super handy as well. Sep 17, 2022 at 12:51
  • Just to make sure: Your min and max are about 2200 units apart and your terraces are much worse than the ~0.03 units of precision introduced by the conversion to UInt16 (~2200/~65000)? Sep 17, 2022 at 12:55

2 Answers 2

0

Apparently, Blender supports float32, so there is no need to convert to UInt16 - see the comment by the author on this question

If you can't get float32 working in Blender, try the second answer in the link, but that doesn't work for me, so if you do find a solution, please let us know.

1
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Sep 25, 2022 at 7:50
0

I had similar issues and it disappeared when using only displacement and not displacement+bump (under material properties/settings/surface/displacement set to displacement only. It is related to shallow gradients but other than the above not perfect solution I have not figured it out.

2
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Nov 10, 2022 at 22:14
  • If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. - From Review Nov 10, 2022 at 22:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.