I have been trying many times to georeference a simple plan but I continue to get the error "Transform Failed: Could not create destination file". I have changed folder locations, tried different settings and it still happens. I did manage to get it to georeference once when I first changed folder locations of the output file but needed to do it again as it was skewed.

I am on Windows 11. Could it be some sort of folder permissions issue?

  • Have been dealing with the same thing. Tried modifying the output name like you suggested and it didn't work.
    – user212136
    Sep 19, 2022 at 17:33
  • I find the Georeferencer hit and miss. Sometimes it works. Sometimes it doesn't. But as Al rl suggested in my case the original file is in use, which is why renaming it would have fixed the problem. Doesn't help you though. Is yours a permission issue perhaps?
    – Josh
    Sep 20, 2022 at 22:55

5 Answers 5


Unchecking "Set target resolution" solved the problem for me.


I had similar problems when trying to use georeferencer in QGIS 3.26.3. Added .TIF to georeferencer, placed some reference points (residual less than 0,5 m), then tried to click "Start Georeferencing". Referencing failed. Tried to go to Georeferencer settings, changed the output file name and tried again with no luck. Then I went back to settings, clicked "set target resolution" and did not change anything else. Tried to play "Start Georeferencing" and it did the job like a charm. Went back to settings and again clicked "set target resolution" and tried, then again the referencing job went through. Then Tried this with a new TIF file, placed some reference points from map, clicked "play" and again referencing failed. Went to settings, clicked the box of target resolution and tried again, the referencing job went through again like it should. So in my opinion, there seems to be some sort of bug, which prevents the referencer from working properly without first changing some settings for the referencer. It does not matter, at least in my case, if i renamed the output file, but changing some other settings "there and back" seemed to resolve my problem.

ps. Windows 10 21H2

  • 1
    I might raise this to the development team to see if some tweaks can be made.
    – Josh
    Oct 18, 2022 at 22:47

It looks like the naming of the output may be an issue. It worked when I called the output 'modified', rather than the original file name with modified as a suffix.

  • Obviously, the original file is in use, you can't replace it.
    – Al rl
    Sep 17, 2022 at 11:01
  • Good point. It would be good to have a warning but I will keep that in mind for next time.
    – Josh
    Sep 20, 2022 at 22:53

Really I don't know what's going on behind this but I just unchecked the "Set Target Resolution" and then it worked for me.

  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Mar 2 at 8:16

I had the same issue with 3.26.3 on Windows 11.

When I opened the same project on Mac with v3.24.1 I had no issues with the Georeferencer.

  • It's happening again for me now and renaming the output isn't working. Is this to do with Windows 11 permissions?
    – Josh
    Oct 7, 2022 at 23:38
  • I am finding the Georerencer tool is always hit and miss whether on the Mac or Windows. One minute it fails to create destination file. Next minute it works but the result is wrong (and I am adding points in the correct order and I've used this many times in the past where it has worked). If I close and reopen QGIS it might allow me to georeference a few times but it isn't right. Are there other Georeference plugins out there I could try?
    – Josh
    Oct 8, 2022 at 0:18
  • OK, for now it is working. My output coordinate system wasn't matching the project, which would have caused the terrible result.
    – Josh
    Oct 8, 2022 at 0:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.