I have been tasked with editing the attributes and fixing geometry of a feature class in a shared geodatabase. The feature class is not in a feature dataset. I decided to export the feature class into a separate geodatabase with a feature dataset in order to set up topology rules on the data and clean it up. Once I finished cleaning the data, I deleted all rows in the original dataset and imported my cleaned up data. Everything worked perfectly.

However, now there is something strange happening with the data. When I "zoom to layer" on my copy of the data, it does what is expected and shows the full extent of the data: Correct Zoom

However, when I zoom to layer of the corrected data after I imported it back into the shared geodatabase, it shows an extent much larger than the actual data: Incorrect Zoom

Each feature class contains identical data. But when I compare the extents of each feature class, they are different. The extents of the data in my copy: Correct Extents

The extents of the data after it was imported back into the shared geodatabase: Incorrect Extents

Is there a way to reset the extent of the feature class?

I'm reminded of a similar issue that has occurred in MapInfo that was fixed by packing the table's geographic data.



In my experience, in ArcGIS, Extent doesn't mean what you would expect it to mean. The Extent is not the minimum Bounding Box of all features. It is the maximum possible extent of all features according to ArcGIS. Why that would be useful, is beyond me.

However, there are a few things to correct the extent. Most of them are via ArcObjects, but this Addin could be useful: Update Feature Class Extent

  • Brilliant! That worked perfectly. That was a simple, easy and quick solution. Thanks. – Fezter Dec 17 '12 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.