2

I am very new to QGIS. I have a DWG file containing vector layers and I am using Project>Import/Export>Import Layers from a DWG/DXF. Some layers are then visible in the map, but others are not. When I try to "zoom to layer" on the invisible layers, nothing happens.

When I click on the feature count for one of the "lines" layers, it says there are 124140 features. Almost every other "line" layer throughout all the groups has 124140 features. Could it be that the line layers are all overlapping?

Invisible layers The "lines" feature under I-LAB-FURN should be very prominent in this section of the map, but it is completely invisible.

Some things I've tried:

Merging layers Checking CRS consistency (there might be something I'm missing here)

Unchecking "Expand block references" and "Use curves"

Converting DWG to DXF and then importing. This causes nothing to show up instead.

What else could be the problem?

1
  • 1
    Where did you get this DWG file? It's possible that some layers were turned off in the original drawing. Can you post the drawing?
    – Pointdump
    Commented Sep 22, 2022 at 17:30

2 Answers 2

1

A lot depends on how the original dwg was set up. Sometimes features that appear to be in a specific layer in CAD will end up on another layer because the block itself is on that other layer. Sometimes when a block is imported that way it retains the original colour feature (so you may have some white coloured lines). Sometimes the coordinates will end up all over the place because of xrefs and so on.

Here are some general troubleshooting ideas:

  • Go to your QGIS Project Properties and change the background colour of your project to grey or black to see if anything shows up - the missing lines might be white in colour.
  • Try going into the attribute table for your I-LAB-FURN lines and right click on a row and zoom to feature - see if it's ended up somewhere else. If so, may need to do something to the original dwg to get them all into the right place. Maybe explode blocks and bind all xrefs before importing to QGIS.
  • Try the Another DXF Importer plugin to see if that makes a difference - sometimes it works better than the native dwg importer, sometimes worse.
0

I have a couple of hints for you:

  1. DWG files - You can save your AutoCAD drawing as the DWG 2010 file and try to import it in QGIS. In my case, it worked.
    1. DXF files - check if your file isn't too heavy. If you guess, that it might be the reason, split the file between 2 yet in AutoCAD.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.