0

When I run the code provided below, I get the following warning message.

How I can resolve this error, as this message is returning segment_trees with zero trees?

Message:

In CPL_write_gdal(mat, file, driver, options, type, dims, from,  :
  GDAL Message 1: Setting GeoTIFF 1.1 requires libgeotiff >= 1.6. Key values will be written as GeoTIFF 1.1, but the version number will be seen as 1.0, which might confuse GeoTIFF readers

Code:

library(lidR)

algo1 = dalponte2016(chm_p2r_05_smoothed, ttops_chm_p2r_05_smoothed)
las = segment_trees(las, algo1, attribute = "IDdalponte")

Please note that I don't get this message while using segment_trees with li2012 and silve2016.

3
  • 1
    No idea, never seen that especially no raster is expected to be written here. What I'm sure however is that this issue is OS and/or version specific. So you must report a fully reproducible exemple including data, OS, terra version, lidr version, the output of library(sf) and anything else that may be useful. And I think it is more a bug that must be reported than an actual question to be asked here.
    – JRR
    Sep 23 at 18:41
  • @JRR thank you, unfortunately I can't share the data due to work policies, however I can share the code and the rest of the things lidR/github, will that work? Sep 23 at 19:27
  • 1
    You can certainly reproduce with other data
    – JRR
    Sep 23 at 19:36

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.