0

I am brand new to the world of servers and am trying to set up an open source solution. When I tried to set-up GeoServer it finished it's installation, but I am getting the dreaded "HTTP Status 404 – Not Found". I am not quite sure where to search to find a solution. I have a feeling I am missing something in my Java set up.

Here is a summary of the steps I followed.

I am working on a Windows OS.

I installed Java 11 through Adoptium (jdk-11.0.16.101-hotspot).

I then installed Apache Tomcat 9 using the Full install. After the installation I started the service and opened a web browser to the localhost and received the "If you're seeing this, you've successfully installed Tomcat"

I then downloaded the GeoServer 2.21.1 win set up package and followed the installation. I pointed the Java runtime environment to the jdk-11.0.16.101-hotspot and saw the message "This path is VALID: 64-bit JRE 11 detected". I set my port and chose "Install as a service". I left the installation and data director set to default.

Once installation was complete, I went to the start menu and clicked "Start GeoServer", then checked the service was running, then attempted to connect in the web browser where I received the error. (http://localhost:8080/geoserver)

I've tried looking on the Stack Exchange, Google and YouTube. Most installations seem to be in Ubuntu or Linux so I am having trouble translating the troubleshooting to Windows.

1 Answer 1

0

The issue was that I did not need Apache Tomcat 9 because GeoServer has the jetty included. I uninstalled Apache Tomcat 9 and the issue was resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.