2

When i click on Geoserver Web Admin Page gives Message as 'Bad Request (Invalid Hostname)' in web page. I have already data of on going project in geoserver. I have started Geoserver. My geoserver version 2.1.3. in window Xp operating System. Can any one please guide me to get out of the error and get back Geoserver web Admin Page. Please see the Page result in images below.enter image description here

  • Log files are emply in log folder for the day. – Pari Dec 18 '12 at 11:42
4

i think this problem stems from your 8080 port is occupied from another app. if you want to change your GeoServer port follow this way.

  1. find your startup.bat under GeoServer bin folder.
  2. open it startup.bat with notepad++
  3. find GeoServer serving port geoserver-Djetty.port = 8080 and change it.
  4. restart your GeoServer

    i hope it helps you...

  • This worked in one system. but other system doesn't not have this geoserver-Djetty.port = 8080. In that case what should i do?. There i can see only "call "C:\Program Files\GeoServer 2.1.3\wrapper.exe" -t wrapper/wrapper.conf" in startup.bat file. – Pari Dec 19 '12 at 4:19
0

I had the same problem with 8080 port, I uninstalled the software the reinstalled it, during the installation i changed the port into 8180, the problem remain, i download a file from this link https://github.com/boundlessgeo/gsconfig i run the sutup.py file, then it worked

  • That shouldn't have changed anything. That library is for interacting with GeoServer, and installing the library will not affect whether or not you can connect to an instance. – Alex Leith Apr 1 '17 at 0:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.