7

I run QGIS 1.8.0 Lisboa on a Windows 7 machine. Yesterday I attempted to install the TauDEM plugin using these instructions: http://lists.osgeo.org/pipermail/qgis-developer/2012-June/020807.html

Since doing this the GDAL tools for QGIS do not work with error:

The process failed to start. Either the invoked program is missing, or you may have insufficient permissions to invoke the program.

I understand this means they cannot find the GDAL executables. However, neither can I. Where actually are the GDAL executables in the QGIS folder? I assume I then have to add this manually to the Environmental Variables or into the GDAL tool settings in QGIS - is this correct?

PS. I can run GDAL tools through the OSGEO4W Shell so GDAL itself is alive and well.

  • What do you mean exactly by GDAL tools? Do you mean gdalwarp and the others? – R.K. Dec 19 '12 at 12:59
5

They should be in the (C:\path_to\ )OSGeo4W\bin folder.

4

OK I solved it. In the Environmental System Variables the "(C:\path_to\ )OSGeo4W\bin" path was missing from the PYTHONPATH variable. Adding it results in all the tools working again.

1

For the sake of Ubuntu users, I found the gdal executables in /usr/bin. Try entering

which gdalwarp

into a terminal to see where the system goes for the known command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.