0

I am trying to merge two raster images but the result turns out to be the one shown in the screenshot below. Does anybody know how to fix the problem?

After merging

This is before the merge, but it is what I hope to achieve after merging. Before merging

These are the parameters that I am using. enter image description here

I believe this to be a mismatch of the CRS between the raster. Therefore, I have used the Warp function to standardise both raster to be EPSG:3379 - GDM2000 / Pahang Grid, and merge them again. But this turns out to be the result, only one side is showing: enter image description here

I have tried doing it again (Reprojection and merge), now only other side is showing:enter image description here

I am not sure where went wrong.

3
  • 1
    Can we see the parameters you used for merging? And maybe the general location of your study area?
    – ChloeG
    Oct 26, 2022 at 6:17
  • Done, thanks. Sorry for not providing any details beforehand.
    – Gene Yan
    Oct 26, 2022 at 8:46
  • What you see is normal if you think that the map area is covering longitude area from -180 to +180 degrees. You probably want that the canvas would be from 0 to 360 degrees for preventing the clip at the dateline. Does this sound reasonable?
    – user30184
    Oct 26, 2022 at 9:45

1 Answer 1

0

I believe the error shows up in your screenshots: the merge algorithm is not able to transform your EPSG:3379 - GDM2000 / Pahang Grid rasters to the project target CRS on the fly. There's a way to avoid it and solve your issue.

I tried to merge two raster (Raster1 & Raster2) with the same settings as yours and get the same error and unexpected merged raster.

If you Warp/reproject both rasters first to EPSG:4742 (Reprojected/Reprojected2 in my example below) and then only do the merge operation, it should work fine as illustrated below

Two random rasters provided in EPSG:3379 enter image description here

Merge result of two EPSG:4742 reprojected rasters: enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.