3

I am using QGIS installed via the OSGeo4W bundle. Since version 3.26 I have had an issue with the MapComposer. Upon export, blending modes appear to have no effect. In this case I have a bathymetric map that I used to calculate hillshades on. I tried GDAL, SAGA Analytical hillshade, QGIS-toolbox with various options as well as duplicating the bathymetry and styling that as Hillshade instead of Singleband pseudocolour. I usually add the hillshade over the bathymetry and choose blending mode multiply to reveal the underlying layer. In the main window of QGIS and the MapComposer this works and everything looks good. Only once I export the final map as an image (.tif, .png, .jpeg, .bmp), the hillshade is exported as if I had chosen "normal" as blending mode, i.e. as a greyscale layer overtop my bathymetry.

I had hoped this would change with the next update, but updating to 3.28 has not changed anything. Re-doing the maps from scratch also did not help.

Has anybody has encountered a similar problem? How can I resolve this?

EDIT: Below are screnshots from the MapCanvas and the export.

MapCanvas

export

1
  • 1
    Can you provide screenshots of how you symbology looks on the map canvas and how it looks on the exported map?
    – Erik
    Oct 26, 2022 at 12:16

2 Answers 2

1

I looks like this is a bug currently tracked on QGIS side : https://github.com/qgis/QGIS/issues/50526

1

I have the same issue. For me the bug gets activated when masks are enabled (you also seem to have masks enabled for the contour labels). It's such a frustrating and big bug in my opinion, I am surprised how little traction it has (and am very sad that the bug made it into the current LTR).

The only workaround I found was to add the blending in the layout composer:

  • Remove all blending modes from the layers in the main window
  • Create separate map items (with the same extent & alignment) for every layer(using locked layers/map theme in the layout composer item properties) - add the blend modes to the map items via item properties -> rendering

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.