0

I'm using QGIS 3.22. After right clicking and saving a defined CRS shapefile I open the layer in a new project, but the CRS is unknown. I thought that the Save Vector Layer as function permanently changes the CRS for the layer? enter image description hereSaved Shapefile referencing CRS

enter image description hereLayer properties of saved shapefile showing unknown crs

9
  • Is there a file with an extension ".prj" alongside the ".shp" file (and also a ".shx" and ".dbf")? That's where the projection is stored and if you don't copy every part of a shapefile then this can happen. Which is why I use GeoPackages now.
    – Spacedman
    Oct 28 at 9:29
  • Yes the prj file shows 'unknown'. However I thought by defining the CRS when using the 'Save Vector Layer as' function the CRS is permanently changed? I've tried saving as a geopackage and have the same issue. Oct 28 at 9:38
  • I've gone back to the original shapefile that includes the correct CRS in the prj file. I tried to save specific features from this as both a shapefile and geopackage. Both files when added showed the CRS as 'unknown'. I then tried to use the Reproject process and this also produced a file with an unknown CRS. Oct 28 at 10:45
  • Without a reproducible example it is unlikely we will be able to help you Oct 28 at 11:47
  • What's the CRS of the layer before you start saving it? A quick test with a scratch layer in CRS:4326 is transformed to 3857 when using Save Vector Layer As... as a shapefile. But if your layer initially has an unknown CRS, how can QGIS figure out how to reproject it to your target CRS?
    – Spacedman
    Oct 28 at 11:55

1 Answer 1

0

I uninstalled 3.22.11 previously loaded using osgeo4w and loaded 3.22.12 standalone. No projection issues then experienced.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.