4

I'm trying to install the Statist plugin. I'm running MacOSX 10.7.5. with Python 2.7.3. and Numpy 1.5.1.

I have also installed matplotlib 1.1.0 (for python 2.7). When I try to install the Statist 1.0.0 plugin, I get an error message saying that I need matplotlib installed. Somehow QGIS is not finding it.

  • What version of QGIS are you using and how did you install matplotlib btw? – R.K. Dec 20 '12 at 1:28
3

It is always the same problem of PATH: the QGIS version of Kyngchaos uses exclusively the standard Python installed in Mac OS X and not those installed from Python.org, with Homebrew, MacPorts or Fink, see my answer in QGIS Python version.

2

You can try Fink version of QGIS. It recognizes python modules installed by Fink. Another reason I recommend Fink is I am the maintainer of QGIS for Fink. ;-p

1

You can try using the KyngChaos build of Matplotlib and see if it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.