I have a feature layer consisting of 96,000 features, but we are displaying a maximum of 13,000 features in our map application. There is an issue that for some zoom levels the features are visible and for other, intermediate zoom levels the features are not visible. I have deleted the feature class and restarted the service in case there is issue with the feature class, but that also did not help.Thank you in advance and any kind of help will be appreciated.

1 Answer 1


Have you tried clearing the ArcGIS server rest cache?


Also you cleared the browser cache/tried a different browser?

  • I guess it is for Arcgis server 10.0 and not for 10.1...
    – Gunner
    Dec 20, 2012 at 9:19
  • Its still possible to clear the rest cache at 10.1, although it does say it should be automatically cleared "automatically updates the REST cache when you add, update or remove services and folders". I'd try it anyway: http://[host]/arcgis/admin/system/handlers/rest/cache/clear via servicesbeta2.esri.com/arcgis/sdk/rest/clearcache.html Dec 20, 2012 at 10:03

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .