0

I am trying to display geometry sizes by numerical weight with the geometry size assistant in QGIS and am using this GeoJSON layer:

https://raw.githubusercontent.com/ieg-dhr/DigiKAR_Projektseminar/main/GeoJSON%20layers/Domherren_v6.geojson

The size assistant permits me to select the place_count as well as the e_count columns but ignores the s_count column. Why is that? I could not find an error in the GeoJSON file that would prevent the data from loading.

EDIT:

I have now figured out that QGIS sees that data column as an "ABC" (text) column although all values are numerical and not strings. I could not identify any strings in the column and would like to know how I can change its "type" in QGIS without downloading the data from QGIS and importing from my local drive.

1 Answer 1

1

Sounds like some bad version of GDAL or QGIS might be involved there, it works fine for me on QGIS 3.26.3 with GDAL 3.5.1. All three columns are detected as numeric values.

As a workaround you can use an expression instead of the vanilla column. Click the Epsilon (like an mirrored "3") next to the dropdown where you can select the column and enter the expression to_int("s_count").

3
  • Thanks! At the end of the day, I just downloaded the file and it worked, but pulling it in directly from Github as a raw file is much handier. I will definitely update to the latest version of QGIS. I have had quite some glitches for the past few weeks. Nov 2, 2022 at 18:24
  • Oh I missed that in your question. It works when opened locally but not when opened as remote file? It seems to work for me if I copy and paste the URL into the Data Source Manager's Vector dialog as well. Nov 2, 2022 at 18:32
  • 1
    Yes, for me it only worked locally but not remotely. Nov 2, 2022 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.