1

I am attempting to pass 1,400 distance values into the multiple ring buffer tool using a model I created based on the answer to the following question asked 9 years ago regarding this question (ArcMap instead of ArcGIS Pro). See previous question/answer here: How to pass distances to Multiple Ring Buffer in ModelBuilder?

I was able to successfully replicate the nested models in ModelBuilder, but it seems as if there is a ArcGIS Pro python issue with passing a table of values (distances) for the multiple ring buffer tool. I am using ArcGIS Pro version 2.8.29751 When I run attempt to run the model, I receive the below error next to my Input_Features of the multiple ring buffer tool:

ERROR 032659 updateParameters Error: Traceback (most recent call last):
  File "C:\Program Files\ArcGIS\Pro\Resources\ArcPy\arcpy\arcobjects\_base.py", line 90, in _get
    return convertArcObjectToPythonObject(getattr(self._arc_object, attr_name))
AttributeError: ParameterObject: Get attribute: values does not exist

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "c:\program files\arcgis\pro\Resources\ArcToolbox\toolboxes\Analysis Tools.tbx\MultipleRingBuffer.tool\tool.script.validate.py", line 71, in <module>
    if shape_type != 'Polygon':
  File "c:\program files\arcgis\pro\Resources\ArcToolbox\toolboxes\Analysis Tools.tbx\MultipleRingBuffer.tool\tool.script.validate.py", line 46, in updateParameters
    input_fc = self.params[0].valueAsText
  File "C:\Program Files\ArcGIS\Pro\Resources\ArcPy\arcpy\arcobjects\_base.py", line 96, in _get
    (attr_name, self.__class__.__name__))
NameError: The attribute 'values' is not supported on this instance of Parameter.

Main Model:

Main Model

Sub Model:

Sub Model

I haven the set the Distance column as the group field in the iterator so that shouldn't be the issue.

Is this type of model compatible with ArcGIS Pro where a list of values based off a field (type double) are used as the input to the distance parameter in the multiple ring buffer tool?

I have tested the nested models in ArcMap 10.5 and it worked successfully. The issue is run time. If I'm able to run in ArcGIS Pro, I suspect that ArcGIS Pro would run quicker but maybe not. I also tested to see if this was because I had too many distances by deleting all, but 4 rows of distance values and it still doesn't work in ArcGIS Pro.

1
  • The error occurs once I hit the Multiple ring Buffer tool. So, it collects all the values but reads an error with the point featureclass I'm using. I've tried exporting to a shapefile and also re-exporting to another GDB as well as other point featureclasses but same error. I receive an input error for Multiple ring buffer before even running. The values actually get passed in when I run but the tool is greyed out with the above error. Nov 9, 2022 at 22:25

1 Answer 1

1

You need to read and understand what the help file is telling you. The distance parameter is a list of doubles as stated here but you say you are "...passing a table of values...". A table is not a list. So I suspect you need to correct the output data type of the Collects tool.

As a side note passing a list of 1,400 values into the multi-ring buffer tool sounds like an insane number to me? What requires 1,400 rings around it? I could imagine the tool might be very slow at process that?

On the plus side the use of sub-models to collect values is the right way of doing this processing.

5
  • 1
    I incorrectly stated that I am using a table. I am passing a list of doubles into the collect tool in my sub model. Also, my error message reads next to my input features before I ever run the multiple ring buffer. I successfully ran this tool in ArcMap 10.5 (6+ hours runtime). However, with ArcPro it will not allow for the list to be used for the multiple ring buffer in the main model and presents the error I have in my question above. I'm using the field type double for my distances. I tested to see if this was because I had too many distances by removing all but 4 and it still doesn't work. Nov 10, 2022 at 14:48
  • @ConnorGarrett I just replicated your model and it works fine for me, I am using a FOR iterator to generate the number sequence. I think you need to edit your question and show how you are setting up the individual tools?
    – Hornbydd
    Nov 10, 2022 at 18:38
  • did you do this in ArcPro or Desktop? The script works for me in desktop but I'm not able to get an input feature into the multiple ring buffer without receiving the red X error with the above error message in the question. Nov 10, 2022 at 20:03
  • Works fine for me, I'm using ArcPro 3.0.2....
    – Hornbydd
    Nov 11, 2022 at 1:32
  • I think this has something to do with the ArcPro version then. I can't figure out why the multiple ring buffer won't accept the list of distances being passed into it. Nov 14, 2022 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.