Not for the first time, QGIS has broken due to unsatisfied package dependencies. This is not surprising, as I'm using the 1.9 Master version which is released nightly, and the package dependencies seem to update rapidly.

Most recently, for example, QGIS could not reinstall due to the following package dependencies.

Depends: libc6 (>= 2.14) but 2.15-0ubuntu10.3 is to be installed
      Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is to be installed
      Depends: libqt4-network (>= 4:4.5.3) but 4:4.8.1-0ubuntu4.3 is to be installed
      Depends: libqt4-sql (>= 4:4.5.3) but 4:4.8.1-0ubuntu4.3 is to be installed
      Depends: libqt4-svg (>= 4:4.5.3) but 4:4.8.1-0ubuntu4.3 is to be installed
      Depends: libqt4-xml (>= 4:4.5.3) but 4:4.8.1-0ubuntu4.3 is to be installed
      Depends: libqtcore4 (>= 4:4.8.0) but 4:4.8.1-0ubuntu4.3 is to be installed
      Depends: libqtgui4 (>= 4:4.8.0) but 4:4.8.1-0ubuntu4.3 is to be installed
      Depends: libqtwebkit4 (>= 2.2~2011week36) but 2.2.1-1ubuntu4 is to be installed
      Depends: libspatialite3 (>= 3.0.0~beta20110817) but 3.1.0~rc2-2~precise1 is to be installed
      Depends: libsqlite3-0 (>= 3.5.9) but 3.7.9-2ubuntu1.1 is to be installed
      Depends: libstdc++6 (>= 4.6) but 4.6.3-1ubuntu5 is to be installed
      Depends: qgis-providers (= 1.9.0+git20121208+7841975~precise1) but 1.9.0+git20121208+7841975~precise1 is to be installed
      Depends: qgis-common (= 1.9.0+git20121208+7841975~precise1) but 1.9.0+git20121210+df2c1c5~precise1 is to be installed

The strange thing for me is that more up-to-date versions of the dependent packages already seem to be on my machine, based on the above warning.

I know the simple answer to this question is "use 1.8.0 if you cannot sort your dependencies out", and this is precisely what I've done for now - (see very useful answers here if you need to fix broken packages).

However, I really like using some of QGIS's new features such as the new labelling engine and would also like to contribute to the development process by submitting up-to-date bug reports.

So if anyone has faced similar issues and knows of a reliable way to keep abreast with all QGIS 1.9 dependencies, please let me know.

  • All the to-be-installed packages seem to have newer versions, where do you see the problem? It's odd that qgis-common has a different hash in the version than qgis-providers though. Dec 20, 2012 at 21:12
  • Indeed - all I know is that QGIS refused to update, and that was the message supplied by the software centre. Synaptic provided similar messages. Dec 20, 2012 at 21:35
  • 1
    qgis-common is the problem there, since it wants that exact version. It looks like you updated at a bad time and only some of the packages were new at that point with both qgis and qgis-providers being older (7841975 is an older revision than df2c1c5). From what little I've hung out on #qgis, generation bugs do happen now and then, so it's best to ask on IRC directly. Dec 20, 2012 at 22:20

2 Answers 2


Install from source

Thanks to lynx for the tip to ask on the IRC channel, there one of the developers (NathanW) suggested installing from source directly.

The advantage of this method is that there is no chance package dependencies can get mixed-up. Assuming you're running linux with apt, all necessary packages (excluding ccmake) can be reliably installed with a single command (described here):

apt-get install bison cmake doxygen flex git graphviz grass-dev libexpat1-dev libfcgi-dev libgdal1-dev libgeos-dev libgsl0-dev libopenscenegraph-dev libosgearth-dev libpq-dev libproj-dev libqt4-dev libqt4-opengl-dev libqtwebkit-dev libqwt5-qt4-dev libspatialindex-dev libspatialite-dev libsqlite3-dev pkg-config pyqt4-dev-tools python python-dev python-qt4 python-qt4-dev python-sip python-sip-dev txt2tags xauth xfonts-base xvfb

Once these packages are installed, it's plain sailing: you just clone the latest Github version onto your system with the following command:

git clone git://github.com/qgis/Quantum-GIS.git

Because github is where most updates are added directly, this method ensures you're getting the bleeding edge version. Also, you choose where the binary goes, so I guess it allows multiple versions to co-exist. The Ubuntu-gis solution suggested by Curlew should work in theory, but I've found it unreliable...

All the install from source instructions, including how to install Master on Windows and other operating systems can be found here (the this is just the html file linked to previously loaded to dropbox).

Following these instructions is, I believe, the most reliable way to get the latest version of qgis on your system. Here's a screen grab from my system:

qgis 1.9.0 Master

Many thanks to the qgis developers for making such an excellent piece of software, while also being supportive to the community. Hope to contribute to the project more now, by testing and bug reports. Any suggestions on that welcome, but probably way off topic by now. Apologies for long reply to my own question. Still learning all this stuff!


You can find sources with updated dependencies on the QGIS download page. If possible try to add the official repositories to your sources. Also look into other posts here on stackexchange (look to the right).

If it still doesn't work, you should go the usual way with broken dependencies (correct them piece by piece, try different sources, create symnlinks for packages or just compile QGIS yourself. It isn't really hard.).

  • Thanks Curlew. Following 2.6.2 from the download page you linked to, I installed a fully operational version of QGIS. It's only 1.8.0, however, so does not quite answer my question. Following section ubuntugis, I'm making better progress, but still cannot install QGIS 1.9. After following all the steps, Synaptic produces the following message: "Could not mark all packages... The following packages have unresolvable dependencies... qgis: Depends: qgis-common (=1.9.0+git20121208+7841975~precise-ubuntugis1) but 1.9.0+git20121210+df2c1c5~precise-ubuntugis1 is to be installed" Dec 21, 2012 at 8:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.