1

I have a project and I want to create a map using SRTM as a background. I upload it ... and it looks like that: general view

But my project area is smaller, so I need to zoom it ... and when I do that, my SRTM looks like that: enter image description here

What can I do so the raster doesn't look so pixelated?

2 Answers 2

5

Hillshade is only as good as the quality (resolution) of the underlying DEM. What you can do is changing the resampling mode from Nearest Neighbour (default) to Bilinear (recommended for elevation/hillshade) or Cubic. You find these settings in Layer Styling Panel / Symbology at the bottom.

See this explanation about the difference between Nearest Neighbor, Bilinear Interpolation and Cubic resampling for the theoretical background - the principle is the same in QGIS as in ESRI software. Short version:

Nearest Neighbor can be used on continuous data but the results can be blocky.(...) Bilinear Interpolation uses a weighted average of the four nearest cell centers. (...) it should be used for continuous data like elevation and raw slope values.

See also What is Bilinear Interpolation?

Enlarged section from the screenshot below - left: resampling mode Nearest Neighbour, right: Bilinear:

enter image description here

enter image description here

See here the settings and the result: enter image description here

1
  • 2
    When you enable "Early resampling" you get more options for resampling, I highly recommend Cubic Spline for nice looking hillshading when zoomed in to coarse DEMs. May 24, 2023 at 9:32
2

It looks like you are rendering the DEM as a Hillshade which is the part resulting in the pixellating.

I don't know why but when zooming on DEM layers with a Hillshade Style rendering in QGIS, it is made of uniform grey pixels with graduated contour lines as pictured below

a) Raw DEM (Singleband Pseudocolor): enter image description here

b) Hillshade rendering when zoomed in: enter image description here

I would recommend you to:

  1. reproject the SRTM DEM to your project CRS: enter image description here with Hillshade rendering there is still an unexpected rendering when zoomed in but there are no aliasing effects

  2. use the Processing Toolbox>GDAL>Raster Analysis>Hillshade to create a new Hillshade layer:enter image description here By being reprojected there are no aliasing effects and being a native Hillshade layer, each pixel has the actual hillshade value

With that, and depending on what you specifically want to achieve, you shoudl be good

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.