0

I have a network downloaded from Open Street Maps on which I want to run the Grass v.net.centrality tool. I've tried everything I can think of, including reinstalling QGIS (I've tried multiple versions of QGIS such as 3.26, 3.28 and 3.22 (the most recent stable version)), I would clean the cache everytime I reinstalled, I've experimented having the files in different locations, I've tried creating a file as output (instead of creating a temporary file). I even created a project with just a newly fresh download OSM network layer, and the problem persists. Every time I run v.net.centrality, I get this outcome (as you can see in the image print):

The following layers were not correctly generated

print

EDIT:

Error text:

The following layers were not correctly generated.

•C:/Users/JC/AppData/Local/Temp/processing_kdTmKX/6810eb6f10ff45368718d9816ff5e8a8/output.gpkg

You can check the 'Log Messages Panel' in QGIS main window to find more information about the execution of the algorithm.

I've noticed that none of the Grass tool functions. I've tried initializing Grass as an individual program (the 7.8.7 version that comes with QGIS) and also installed the most recent stable version 8.2. I can't initialize any of them. The Grass prints are form the 7.8.7 version that comes with QGIS. I created the grassdata folder inside Documents folder and chose a new location (basic cartesian) so I could start GRASS session, but it gives me the error in the command prompt print. I should add that I have Python 3.10 installed, as I've seen in other posts that the Python version may cause problems.

EDIT 2: while running the GRASS tool on QGIS, I've noticed this message (see last print):

Starting GRASS GIS... ATENÇÃO (ATTENTION): Concurrent mapset locking is not supported on Windows Cleaning up temporary files...

Maybe this could be the source of the problem, I don't know.

Parameters print

grass initial window

grass error

qgis grass error complete

3
  • 1
    Maybe a print screen with the parameters you are using and a sample dataset would be helpful.
    – Nikos
    Nov 30, 2022 at 19:03
  • 1
    Please always provide full error messages as formatted text and not only in a picture.
    – PolyGeo
    Dec 1, 2022 at 8:38
  • Thank you. I've added the text error as formatted text and put some new print screen, including the parameters, and prints related to the individual Grass program
    – John Silva
    Dec 1, 2022 at 8:53

1 Answer 1

0

Try GRASS GIS version 7.6. Versions 7.8 - 8.2 do not run trouble-free on my Windows machine except when called from R. "Concurrent mapset locking is not supported on Windows Cleaning up temporary files..." should not be the source of error. If you want to share the network in question I can have a look if it works on my setup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.