I am using ArcGIS API for Python.

When I install Jupyter_client==7.1.0, I get error of arcgis 2.0.1 requires jupyter-client<=6.1.12, but you have jupyter-client 7.1.0 which is incomatible.

When I install jupyter-client==6.1.12, I get error of spyder-Kernels 2.2.1 requires jupyter-client>=7.1.0 and jupyter-console 6.4.3 requires jupyter-client>=7.0.0

How can I solve this issue?

  • Is "arcgis 2.0.1" the same as ArcGIS Pro 2.0.1, or is it something else?
    – PolyGeo
    Commented Dec 12, 2022 at 7:45
  • 1
    @PolyGeo no, ArcGIS API for Python Current version: 2.0.1 - June 3, 2022. Release notes
    – user2856
    Commented Dec 12, 2022 at 8:22


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.