I've a TIFF-file. Loading the raster image into QGIS does not display correctly. (Using the Add raster layer button.) It seems to be distorted with noise. See image below:

qgis (l), image viewer (r)

The source of the TIFF file is a 300 dpi scanned document. Other scanned documents display correctly.

Projection doesn't matter as the image is not georeferenced yet.

I'm using qgis-1.7.0 in a sabayon-linux environment.

What's the source of this problem? Did anyone else encounter this before? Thanks for any hints or experience on this topic.

  • 1
    Can you check what raster style is used under Layer Properties -> Style – Nathan W Dec 26 '12 at 12:59
  • Three Band Colour. That's it! – Waqar Lim Dec 26 '12 at 13:00
  • hmmm can you post a screen shot of that for me – Nathan W Dec 26 '12 at 13:02
  • 1
    It's a greyscale image but the import tried to display 3 bands. Your hint was correct. Switching style to single band fixed it and the raster layer displays correct. – Waqar Lim Dec 26 '12 at 13:09
  • 3
    Do you want to post that a answer to you own question. After 2 days you can accept it. You will get rep, and it will also close this question. – Nathan W Dec 26 '12 at 13:14

Qgis does not know this is a grey-scale image and tries to display 3 bands.

Opening the layer properties and the style tab allows you to switch back to grey-scale (single band grey) from coloured style (three band colour).

Thanks Nathan W for pointing out to check layer style properties.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.