0

I used external WMS layer (EPSG: 3112) as a base map for my local WMS layers. WMS owner stopped to provide WMS and has WMTS getcapabilities link instead. I never worked with WMTS before.

I have added it as a WMTS store and published layer. It's projection is 3857 (recognized by GeoServer). I can view it in Layer Preview section successfully.

The thing is that I need to visualize it with my own other WMS layers, which are in EPSG:28356. And it is not visible probably due to another projection. I don't understand how to change it. I tried to assign 3112 and 28356 and played with Bounding Box coordinates, but none of the options work.

Here is settings of the new WMTS layer:

enter image description here

This is settings for old WMS, which is not provided anymore:

enter image description here

In GeoServer documentation I saw that it should be able to reproject dynamically:

Connecting a remote WMTS allows for the following features: Dynamic reprojection. While the default projection for a layer is cascaded, it is possible to pass the SRS parameter through to the remote WMS. Should that SRS not be valid on the remote server, GeoServer will dynamically reproject the tiles sent to it from the remote WMTS.

But I don't understand how to use that properly.

4
  • do you get any error message? anything in the log file? what URL are you requesting WMTS or WMS?
    – Ian Turton
    Commented Dec 16, 2022 at 6:35
  • This service: spatial-gis.information.qld.gov.au/arcgis/rest/services/… If I assign epsg:28356 (in Declared CRS, force declared option and assign BBox: compute from data and compute from native bounds) - it is still can be previewed, but not visible together with my other layers in 28356. Do I need to create a special Gridset for the reprojection? docs.geoserver.org/latest/en/user/geowebcache/webadmin/… Commented Dec 16, 2022 at 16:54
  • No you need to put in the actual projection of the remote layer, geoser will handle the reprojection for you.
    – Ian Turton
    Commented Dec 16, 2022 at 16:58
  • Thanks, good to know! Unfortunately, when I publish it as it is in 3857, it is visible in Layer Preview solely, but not visible together with locally hosted WMS layers in 28356. Don't know what else to check. How to make it auto reprojected by GeoServer. Commented Dec 19, 2022 at 9:55

1 Answer 1

1

I imported that server as a WMTS store, simply paste in the GetCapabilities URL (https://spatial-gis.information.qld.gov.au/arcgis/rest/services/Basemaps/QldBase_Pastel/MapServer/WMTS/1.0.0/WMTSCapabilities.xml) and save.

Then to publish the layer I left the settings as GeoServer set them:

enter image description here

The layer then shows up in the image preview using EPSG:3857 but is perfectly happy to be shown in EPSG:4326 in QGIS

enter image description here

You simply request it from GeoServer in the projection you require and the reprojection is handled for you in the same way as any other layer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.