0

When attempting to export OSM basemap as a tiff image the results show many tiles missing. My process is as follows:

  1. I load a rectangle polygon to serve as my mask
  2. I set the mask at a scale of 1:5000 (for the detail I need)
  3. I set the magnifier at 23% so I can see the entire mask in my view
  4. I then load OSM using WEB / QuickMapServices / OSM / OSM Standard
  5. I wait for all the tiles to load.
  6. I then select Project / Import-Export / Export map to image
  7. In the Save Map as Image Window I I choose my mask to calculate the extents
  8. Scale is set at 1:5000
  9. I set resolution to 300dpi
  10. Save filename and process. Can take up to 2 minutes The result is sometimes I get an excellent, detailed image. But lately 90% of the time the image is incomplete. I have a new fast PC, 5GHz, 64GB DDR5 6000 RAM. I have tried the “stable” version of QGIS (3.22), and the latest 3.28 version. Tried MapTiler and the results were actually worse. The map would not even fully load onto the screen. I have researched others with the same issue but have not found a definitive answer.

Can someone tell me where I am going wrong? Am I getting blocked from OSM? Do I need a key or token or something. Please help.

4
  • Could it be that export with 300 dpi does not use the cached tiles but tiles from higher zoom level and they are fetched from the tile server during the export? And that the tile usage limits operations.osmfoundation.org/policies/tiles get hit then, or tiles are just coming too slowly?
    – user30184
    Commented Dec 15, 2022 at 17:13
  • @user30184 You are probably right, I had a look and OSM tiles at 1:5000 displayed at 23%, even with cache size increased there are timeouts/errors just to load all the tiles in the map view
    – Kasper
    Commented Dec 15, 2022 at 17:23
  • You should try MapTiler Vector layer for OSM, it works fine for a large layout at 1:5000, exported at 300 dpi.
    – Kasper
    Commented Dec 15, 2022 at 18:09
  • Thx for above replies, guys. Two things I noticed. I will get the same missing tiles when I attempt a 2nd or 3rd try of the same area. Also, I tried MapTiler and got the same missing results. Since many rave about it I will try it again. Also tried XYZ tiles. :(
    – Clutch
    Commented Dec 16, 2022 at 16:14

1 Answer 1

0

I believe I have found an answer or I should say a "work-around". I divided my extents mask into quarters. Originally the area I was capturing was about 9 miles in distance (105.57 sq. km or 40.77 sq. miles). The resulting image was approx. 875MB.

By dividing into roughly 10 sq. miles I am able to export a map a 1:5000 with 300dpi. I will just have to merge the four images back into one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.