I've created an orthographic projection map, and have added it to a print layout. When I then add a lat/lon grid at 10 degree intervals I get straight lines across the image as well as the curved ones I want. I saw a response to a similar problem suggesting a white fill or making the grid polygons rather than lines, but can't see any options to do this. Here's where I am. It's especially puzzling because I previously created an orthographic image which was identical apart from the map source, and it worked perfectly. AFAIK I didn't do anything differently:

enter image description here

After more trying more options, I find that this only happens at certain orientations, which is strange. When my ortho projection is centred on 40N 15E or 40N 15W all appears fine. For 50W or 80W (which is the one I want) I get the horizontal lines. Here's the parameters I'm using for 50W:

+proj=ortho +lat_0=40 +lon_0=-50 +x_0=0 +y_0=0 +a=6371000 +b=6371000 +units=m +no_defs

1 Answer 1


With non planar projections, the layout Grid sometimes has hard times generating the coordinates. I guess the recommendations you have seen relative to using grid polygons refer to adding a vector grid layer in the map Layers, not as something generated by the Layouts.

The approach behind this is to import vector coordinate grids (from Natural Earth for instance) or generate a vector grid yourself. One thing you sometimes have to do in that case is to "clip those geometries to the hemisphere" you are looking at with your projection, in order to avoid lines to be displayed in front of the sphere instead of circling behind. (There is a 'clip to hemisphere' plugin for that)

Luckily, there is an even simpler plugin called Build Globe View which does all that in one click : you can use it to generate the relevant vector grid, centered on the current view (your custom projection)

Creating the graticule grid, 10 degrees, centered on your projection: enter image description here

From there, the Layout will display the grid as part of your map Layers (and therefore tune the grid rendering from the "Graticule" map layer):

enter image description here

In your case, just generate the Graticule grid as a layer in front of your earth layer and you should be fine.

  • This works well, thanks. The plugin is actually "Globe Builder", with a menu item for "Build Globe View". I was using QGIS 3.10 - this gave errors, and I updated to 3.22 which works. I can't see how to change the graticule width, and I can't work out how to change the graticule colour without deleting the layer and re-adding it. Am I missing something in the menu options?
    – Kognos
    Dec 20, 2022 at 20:02
  • Graticule width can be selected in the Globe Builder parameters. For the colour, I just change the Graticule vector layer Style properties after the plugin has generated it (transparent fill, color line)
    – Kasper
    Dec 20, 2022 at 20:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.