3

In my QGIS installation 3.28.0 on Windows 10, dates are given in Swiss German dialect - like Määntig instead of Montag (as would be in standard German). This is annoying as no one in Switzerland ever uses our dialect in written form - it's just used in oral conversation. So I would like to change these settings. The QGIS User interface of the user profile I use is set to English.

However, I guess the settings depend on system language/localization/timezone settings where I defined german language settings for Switzerland - this makes quite a difference for using the keyboard etc. So I don't want to change Windows setting.

Is there a way to make these changes in QGIS only?

enter image description here

4
  • 1
    Schweizerdeutsch ist echt komisch... ^_^
    – Taras
    Commented Dec 26, 2022 at 11:59
  • 1
    Maybe like QGIS using суржик
    – Babel
    Commented Dec 26, 2022 at 12:08
  • That was funny >_< I did not know that you aware of such words )))
    – Taras
    Commented Dec 26, 2022 at 13:53
  • 1
    I can confirm that this information seems to rely on the system locale also on Ubuntu. Commented Dec 26, 2022 at 16:06

1 Answer 1

1

I found a solution: in Menu Settings > Options > General tab, the entry for Locale was set to Swiss German Switzerland (gsw_CH). When I change it to German Switzerland (de_CH), I get the date in standard german.

So there is no need to make any changes in operating system settings, it's a QGIS setting that was set to this strange dialect version.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.