36

I tried to draw polygons in QGIS 1.7.0 and somehow I can't find or failed to find the "Snapping" option.

I'm used to ArcGIS 10.0 where you have some snapping options, like placing points of polygons at points/edges/shapes/etc., see image below.

Snipping_in_ArcGIS_10

Is this also possible with QGIS? And if yes, how to activate it?

I've tried to figure out all the editing options, but couldn't find any snapping or similar.

45

In Settings / Options / Digitizing, you can define the distance radius in pixel or map units to snap to other points.

Settings

And in Settings / Snapping options you can choose which layers can be used for snapping.

In QGIS 3.12, find this under Project > Snapping options and a new (possibly docked) window "Snapping and Digitizing Options" will appear (in my case, under the Layers panel).

Snapping

The only thing that does not work is snapping to the points of a line or polygon you are just creating.

Software version: QGIS 2.18.20

0
6

Note that in the latest QGIS release snapping options is no longer visible by default. To use it right-click settings to activate snapping options.

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .