While working from terminal in conda environment:

gdalinfo filename

Error is:

Gdalinfo: error while loading shared libraries:
  libLerc.so.4: cannot open shared object file: No such file or directory

GDAL is installed with conda.
There is no library like that.
On CentOS Linux release 7.9.2009 (Core)

How this problem could be fixed?

UPD: gdalinfo --version gives the same error.

GDAL version is 3.5.3.

UPD2: I think the most useful answer is here https://stackoverflow.com/questions/75071381/where-can-i-find-liblerc-so-4-library-for-centos-7/75152579#75152579

  • I have the same error message. Can you find the library with find / -name libLerc.so? I get multiple results (we are using conda-store), so it is definitely installed on my system. It seems that gdal just cannot find the shared library. Jan 13 at 10:02
  • I solved this by updating conda: conda update -n base conda
    – BERA
    Jan 19 at 18:33

1 Answer 1


On Ubuntu I can find both these Lerc related packages:

liblerc-dev - Limited Error Raster Compression library (Development files)
liblerc3 - Limited Error Raster Compression library

So maybe on RHEL subsystems you can try to install this package: https://rhel.pkgs.org/9/epel-x86_64/liblerc-3.1-0.2.gitb1de4cd.el9.x86_64.rpm.html

You will probably have to install dependencies also:

----> dependencies:
    libm.so.6(GLIBC_2.29)(64bit) is needed by liblerc-3.1-0.2.gitb1de4cd.el9.x86_64
    libstdc++.so.6(CXXABI_1.3.9)(64bit) is needed by liblerc-3.1-0.2.gitb1de4cd.el9.x86_64
    libstdc++.so.6(GLIBCXX_3.4.29)(64bit) is needed by liblerc-3.1-0.2.gitb1de4cd.el9.x86_64
    rpmlib(PayloadIsZstd) <= 5.4.18-1 is needed by liblerc-3.1-0.2.gitb1de4cd.el9.x86_64

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.