2

I have imported a large CSV that includes name, lat, long, and altitude. Everything looks pretty decent except that there are a billion lines from each point to the ground causing severe performance and appearance issues.

If I right click on a single entry I can go to the "Height" tab and uncheck "Extend to ground". However, I cannot do this when selecting multiple, or when selecting the parent container. I also do not see how to disable this during import when defining the height field.

How can I disable the "Extend to ground" on multiple (thousands) of data points?

1 Answer 1

3

Yes, unfortunate that there's no option to toggle "extend to ground" ("extrude" in the KML) when importing CSV. Two of the possible ways to deal with this include:

If you're using one or just a few styles, then you can select all the placemarks using that style, merge the styles, and edit the altitude settings just once for the style.

Alternatively, this can be done by editing the KML code itself. What I would do is save the layer out to a KML file, open it up in a good text editor (eg: Notepad++ on windows), find all instances of "<extrude>1</extrude>", and replace them all with "<extrude>0</extrude>". Then save the KML and load it back into Earth.

1
  • 1
    Note, I just updated my answer to include the correct KML "extrude" tags... they were hidden by the StackExchange UI because they had brackets in them, so I had to mark them as code blocks. Should make more sense now (don't replace ALL "1" with "0"). :-) Jan 12, 2023 at 0:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.