I have 4 rasters and am trying to merge them into 2 rasters using the "mosaic to new raster" tool.

I performed this operation successfully for both sets, however, when I went to merge a second set of rasters, I must have forgotten to change the file name, so it overwrote the first one I had created. I therefore ran the second operation again, this time with a new file name (and it also ran fine) before deleting the overwritten file. However, when I went to run the merge it gives error 999999.

I've now spent ages trying to re-run it, change settings, tried clearing temp files, deleted the output folder, even updated the software as I had a pending update. And it just won't work. I tried re-downloading the input rasters, as well as merging other rasters and nothing works. Also there are no underscores or spaces in the file names.

I can't think of any logical reason why it would work one minute and then not the next with the exact same settings and data - and the error message is not very descriptive. Does anyone know why this may happen, or is it just Arcgis being useless?

  • I have found when ArcPro misbehaves, shutting it down and restarting often resolves it...
    – Hornbydd
    Jan 12 at 22:24


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.