I'm trying to make some environment factors with ArcMap 10.7.1 for analysing MaxEnt. I made several factors(raster) but the cells' locations are not matched. I've tried Resample, but did not work.

Follows are my settings for Resample. Please check them and let me know if there is any problem. I'm wroking with "DEM (raster)" and "distance from water (raster made by euclidean distance)". Their cell sizes are same. Input Raster: DEM Output Cell Size: 20 (meter, same with before) Resampling Technique: NEAREST Environments-Processing Extent: distance from water

I've read someone's answer before it can be solved by making a new raster (Create Fishnet → Extract Values to Points → Point to Raster) I think this method is not suitable due to the size and high resolution.

Could you give me some advice for this issue?

enter image description here

  • Resample could work, if used correctly, and you're willing to pay the data quality cost associated with resampling. Please Edit the question to focus on what you have attempted with rasters (Create Fishnet is a vector solution, completely inappropriate for this task): The exact envelopes and pixel sizes for each input raster, the exact Resample command(s) you attempted, the exact envelopes and pixel sizes of the Resample output,...
    – Vince
    Jan 13 at 2:48
  • Thank you for your comment. I edited my question and added more information about it. Could you check it again and give me some advice, please?
    – Isdom
    Jan 13 at 3:14
  • Exact envelopes and pixel counts and/or sizes are needed to understand/explain your problem.
    – Vince
    Jan 13 at 5:59
  • Could you provide a screenshot of your tool parameters? And especially of your environment tab? What I think you need to do is set your reference raster to define cellsize as well as raster extent.
    – ChloeG
    Jan 13 at 7:04

1 Answer 1


What you're looking for is the Snap Raster environment setting. Decide on one raster layer that's your master grid, that you want everything else to align to. Then for all additional raster processing (e.g. Resample, creation of your distance to water raster, etc.) you want to make sure your Environment Settings are set so that Snap Raster = your master grid raster.

The Snap Raster setting will force any newly output rasters to match lower left corners, and then adjusts the upper right corner as needed to make the pixel sizes and locations align. For more details see How the Snap Raster environment setting works.

You can access environment settings on a tool by tool basis, or for a full project. For more details see the Esri documentation on Setting geoprocessing environments.

  • Hello ycartwhelen. Thank you for your answer and it was the thing that I exactly wanted! Finally I could know what was the problem. I've always set up only cell size and extent in environment. Thanks a lot!!
    – Isdom
    May 18 at 12:12
  • Glad it was helpful Isdom. When you find an answer (or question) helpful it's good to click the up arrow to the left of the answer to let other people know it was useful. These votes up (or down for unhelpful answers) help sort answers when there are multiple answers to the same question. When it's your question you can also click the check mark to "accept" the answer as being correct. May 19 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.