1

I'm trying to make a world map using Pseudo-Mercator projection (3857) and Natural Earth's 1:10m raster in QGIS. However, Natural Earth apparently doesn't like Mercator, so it cuts the extent of the raster a few degrees, omitting far East Russia and New Zealand (there's also a missing band of ocean, but I can fix that):

Missing Earth The Warp (Reproject) function fixes the omission, but outputs a much lower resolution image (below):

Ugly Earth Some resampling methods output at slightly better resolutions (Nearest Neighbour shown above), but nothing approaching the original quality. I see there's an "output file resolution" setting, but evidently I don't know how to set the parameters to make that do anything productive.

Another potential workaround I've tried is to change the extent in the Metadata tab of the layer properties, but I don't know what I'm doing there, either.

I would like to print this as a rather large wall map (55x42 inches), so maintaining a high resolution is essential.

1 Answer 1

0

In the Warp dialog of QGIS, you need to compute the pixel size if you want to use the Output file resolution parameter. But you can avoid that and set the output size in pixels and lines too.

I assume you wanted to get a representation of the Pseudo-Mercator projection cartographic image. Which indicates your question although it differs from the screenshots you attached (the projection ends at the antimeridian but your capture continues). In any case, I hope the answer helps you.

Pseudo-Mercator projection image is a square. Suppose you want to print it on a map that is 42 inches on a side, and you want to have 300 pixels in each inch. So you want a 12600 x 12600 raster.

Your original image is likely to be 10800 lines tall. Even if it were 12600, the projection still stretches a bit and discards the extremes (the poles and a bit more), so some Resampling method to interpolate neighbors would be beneficial.

But it is also very beneficial (in time) to define the Georeferenced extents of the output file (in Advanced parameters), to avoid the processor trying to reproject and interpolate out of the image.

  • The (cartographic) image width of Pseudo-Mercator projection is the length of the Equator of a sphere of radius 6378137 meters. So you can multiply the radius by 2 pi, and get the total width in meters: something like 40075016.686.

The origin of coordinates is in the center, so I am going to put the extension between minus and plus 20037508.343. The format in the dialog is xmin, xmax, ymin, ymax.

If you dare to calculate the pixel size (in georeferenced units, i.e. in meters) for the assumed case of 300 pixels per inch, it should give you a size close to 3180.557. Instead, you can leave the widget unpopulated and add -ts 12600 12600 as an Additional command-line parameter. (gdalwarp parameters documentation: https://gdal.org/programs/gdalwarp.html)

Dialog Image

1
  • Thank you, Gabriel! The first time I tried your solution, it resulted in a weird, smeared raster. However, a second attempt yielded satisfactory results. The map is rendered Pseudo-Mercator, but in the layout I have it set up so that Europe and Africa are to the left and the Americas are to the right, with the Pacific in the center.
    – Zak H.
    Jan 17, 2023 at 21:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.