I have an issue when re-opening a QGIS project. I saved and closed it before shutting down the computer. The day after QGIS is whining about missing layers, but the path is correct and there is nothing wrong with the layer. I can import the "missing" layers separately without any issues.

First image shows where QGIS is not able to find the layer. Second image shows the actual location of the layer, which, as you can see, is the very same that QGIS cannot find it.

First image

Second image

I've tried most start-up repair tools, but nothing seems to work.

  • 1
    I would eliminate the possible problems one at a time until it works, starting with dropbox and then the SD card and then the () in the file name and then the spaces in the file name.
    – Ian Turton
    Commented Jan 18, 2023 at 11:07
  • Thanks, I'll try it out. It did cross my mind that the sd-card could be an issue, but then again it is mounted in a way that the system "interpret" it as a none-removable drive. Commented Jan 18, 2023 at 11:54

1 Answer 1


I figured out what the issue is. It's a system limiting deal.

I run Debian and the QGIS project 12500 layers loaded. The project works fine in Windows, but for some reason there's a limit to how many layers can be loaded in one project at a time.

There's probably a proper solution to this, however what I did was splitting up the project into smaller sizes.

  • You have a project with 12500 layer ! how did you manage that ?
    – J.R
    Commented Jan 19, 2023 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.