9

I've been trying to figure out how to stop the labels from moving when dragging the map with the cursor.

here is what happens

Is it possible to prevent this from happening? I am new to QGIS and don't really know what to try to fix this.

1
  • 1
    Please provide your current label settings, as well as a description of how you expect the labels to behave.
    – Erik
    Commented Jan 24, 2023 at 11:25

1 Answer 1

11
  • In Labels tab in Layer Styling (F7), open the Placement tab.

  • Click the Settings button below Label Anchoring.

  • Select Use Entire Line for Clipping and Strict for Placement Behavior.

enter image description here

enter image description here

2
  • 1
    Another option would be to use the datadefined attributes to set the x and y, but that should be functionnally similar.
    – Al rl
    Commented Feb 4, 2023 at 17:02
  • @Alrl You can add this useful option in details as a new answer. Commented Feb 4, 2023 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.