1

I am trying to properly configure the PGeo driver with unixODBC and MDB Tools for my Ubuntu system in order to convert a .mdb file to a GeoPackage. The .mdb file is found here https://nosimagery.noaa.gov/images/shoreline_surveys/projects_zips/EC10a01.zip

I am following the instructions from here https://gdal.org/drivers/vector/pgeo.html

I installed the prerequisites using

sudo apt-get install unixodbc odbc-mdbtools

and updated libmdbodbc to odbc-mdbtools, as the former seems outdated.

My odbcinst.ini file is located in /etc/. I modified, so it now reads, but I've tried various combinations of the two blocks, file paths and file names.

[MDBTools]
Description=MDBTools Driver
Driver=libmdbodbc.so
Setup=libmdbodbc.so
FileUsage=1
UsageCount=1

[Microsoft Access Driver (*.mdb)]
Description = MDB Tools ODBC drivers
Driver     = /usr/lib/x86_64-linux-gnu/odbc/libmdbodbc.so.0
Setup      =
FileUsage  = 1
CPTimeout  =
CPReuse    =

libmdbodbc.so is saved here /usr/lib/x86_64-linux-gnu/odbc/ and doesn't have a zero at the end. I'm not sure if should replace the original block of code in there, or have both, as the instructions just say add.

When I run...

ogrinfo PGeo:ec10a01

in the location where ec10a01.mbd is saved I get the following error

ERROR 1: Unable to initialize ODBC connection to DSN for ec10a01,
...
FAILURE:
Unable to open datasource `PGeo:ec10a01' with the following drivers.
  -> ESRIC
...
  -> PGeo

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.