I know this question has been answered before, 3 months ago, but cannot work out how to join that thread.

I have been using Mt Lion with QGIS successfully for some weeks but now get the 'Cannot be opened..' message on attempting to start. I have reinstalled the GDAL framework Complete but without success.

Any suggestions most welcome!


The core of the error message is:

Application Specific Information: dyld: launch, loading dependent libraries

Dyld Error Message: Library not loaded: /Library/Frameworks/PROJ.framework/Versions/4/PROJ Referenced from: /Applications/QGIS.app/Contents/MacOS/QGIS Reason: Incompatible library version: QGIS requires version 8.0.0 or later, but PROJ provides version 7.0.0

  • According to error message I think you need to update few libraries.. try to update the version OR reinstall I think it will help you and I am researching on your error message.
    – Sunil
    Jan 2, 2013 at 13:09

2 Answers 2


I received the exact same error message. And I found that installing the newest PROJ framework was the only thing necessary to make QGIS work again. Deinstalling QGIS was not necessary.

  • The same to newest Kingchaos QGIS This solution worked fine.
    – srodriguex
    Jun 24, 2015 at 1:54

It looks like your Proj4 is out of date. Maybe try a complete uninstall and reinstall from the Kyng Chaos build:



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.