2

Does anyone know how to enable a time field in the ModelBuilder of ArcGIS Pro?

I am attempting to create a model that takes a newly created feature class and runs "Group By Proximity", which requires the time field to be enabled. Enabling time is easy to do in layers properties when a feature class is in the table of contents but not on a feature class that only exists inside the model.


Point taken on the correct terminology, so I will clarify.

I want to achieve this without manually enabling time in the Contents: https://pro.arcgis.com/en/pro-app/latest/help/mapping/time/set-the-time-properties-on-data.htm

Preferably, I would like to do this in ModelBuilder, but I cannot find any documentation, tips, or evidence that this can be accomplished.

Even the python solution to programmatically enable time seems like a dodgy workaround that involves copying the properties of a completely separate time-enabled feature over to the target feature layer. https://resources.arcgis.com/en/help/main/10.1/index.html#/UpdateLayerTime/00s300000064000000/

Is there a better way to do this? Something more up to date than this solution from the ArcGIS 10 era?

I’m working with ArcGIS Pro and it seems like there should be a much more elegant solution to this.

0

1 Answer 1

2

First of all you keep referring to it as a Feature class, only a feature layer has the time property. So if what you keep saying is true then you will never be able to do it as you have the wrong type of object in your model. There are no tools that alter layer properties in the manner you require, you would typically need to turn on the time property of the layer in a map and reference that layer. So what I would suggest is two things, explore creating a layer in the map, set the time property and then save that as a layer file and its the layer file you add to your model. If that approach does not work you need to abandon modelbuilder and script it in python. You can enable time on a Layer object.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.