5

I use QGIS 1.8.0 for Linux, and I want to draw roads manually on the map.

enter image description here

So according some tutorials, I use Raster>Geoferencer>Geoferencer to import a bitmap image including roads, and set Geoferencer like this screenshot.

However, after "Start geoferencing", the Geoferencer layer didn't appear on the map. Just like this:

enter image description here

I've tried move the reference layer to top and toggle "update drawing order" but it doesn't work.

What should I do?

  • 1
    Which coordinate reference systems (Layer/Project CRS) are you using? – Afr Jan 4 '13 at 10:14
  • TWD67, and all of my layer set as that(including georeferencer) – kuanyui Jan 4 '13 at 11:02
  • What happens if you "Zoom to Layer Extend" (right click)? – Afr Jan 4 '13 at 12:41
2

Look for Settings -> Options, CRS Tab

under CRS for new Layer, you should activate Ask for CRS. and choose your custom CRS.

Standard is EPSG:4326, and the coordinates of your tif are most probably outside the allowed bounds of +-180°/90° of lon/lat coordinates.

  • All of my layer is TWD67-TM2(a common CRS used in Taiwan), including groreferencer. But it doesn't work when georefrencing. – kuanyui Jan 4 '13 at 11:09
  • Qgis Master offers EPSG:3827 and 3828 for that CRS. If you don't want to use that, you can use current GDAL to reproject the tif to a CRS known in your Qgis Lisboa. – AndreJ Jan 4 '13 at 11:17
  • Have tried, but doesn't work :( – kuanyui Jan 4 '13 at 11:22
  • Your screenshot shows EPSG:3857 as project CRS. If you have grabbed the georeference points from the screen, you have to set the target CRS also to EPSG:3857. – AndreJ Dec 16 '13 at 14:23
2

I had the same problem and found that following the instructions at OpenLayers Plugin Error: latitude or longitude exceeded limits worked. They are:

  • set the project CRS to EPSG:3857
  • make sure on-the-fly-projection is enabled
  • add the background openlayers map layer you want load other stuff that might have other layer CRS, like WGS84 in lat/lon degrees
  • save the project

After this georeferencing the image map with CRS EPSG:3857 worked. I wish I knew why.

  • This was the only thing that worked for me too, so weird... – kory Oct 8 '18 at 13:06
1

Try converting the image to be referenced to a jpg instead of a bitmap, it worked for me.

0

Select parameters as following:

  • Transformation type : Linear
  • Sampling Method : Nearest Neighbor
  • Select proper projection system

Screenshot is attached herewithenter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.