0

I'm trying to export a large image to my drive (# of pixels exceeds 1e13 which is the maximum value even after adjusting MaxPixels). In the documentation it states that the image will automatically be split up in tiles, but I just get an error that the file is too large. Especially after you specify a fileDimensions value. Why do i still get an error?

This is the code:

Export.image.toDrive({ 
      image: Image,
      description: value,
      folder: outputDirectory,
      fileNamePrefix: value,
      scale: spatialResolution,
      shardSize: 256,
      fileDimensions: 256
    });
  });

2 Answers 2

0

You are specifying a fileDimensions that is way to big. This would be an image with 2560000*2560000 pixels, way over the GeoTIFF 4 GB limit. Try to export your image using a smaller value for fileDimensions.

Maybe this answer can be of help?

1
  • Thanks for the response, the piece above does indeed cause the tiles to be too large. However, when I change this value to something that should work theoretically I still get the same error. I'll change the code in the question Commented Mar 27, 2023 at 8:31
0

In the meantime i've found the problem. The Image that I was trying to export didn't have any specific information regarding the extent associated to it. After clipping the Images with a geoJson detailing the extent of the research area, the export worked as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.