3

I am using Qgis 3.22.16, and QuickOSM ver 2.2.0.

I have tried to run a query from an observed area in OSM at 1:100000 scale. It is a small town in SE QLD, Australia. When I open QuickOSM, I select highway under the Key dropdown. Leave value empty. Click from Canvas Extent, click run and it comes up with an error at the top of the screen: Over Pass API Download Failed, Connection Timed out. I had done the exact same process a few weeks ago using QGIS 3.22.7 and had no problems.

I have selected remote areas and larger populated areas; it makes no difference, regardless of the size of the town or area.

1
  • 2
    What is your set time out time?
    – Erik
    Commented Mar 25, 2023 at 9:34

3 Answers 3

2

You should have a look to your timeout set in QuickOSM :

QuickOSM timeout

And also in QGIS settings :

QGIS timeout

What is the server your are using in the background ? In QuickOSM settings ?

1

Please upgrade to the latest version 2.2.1 of QuickOSM, the list of Overpass server has been updated.

0

I had the same problem when updating to QGIS 3.22.16. Changing the Server in QuickOSM-Settings, as mentioned by etrimaille, from lz4.overpass-api.de to z.overpass-api.de did the trick. The queries running now without problems.

The actual timeout setting in QuickOSM was not helping, the query timed out even before the set timeout.

2
  • 1
    Please use overpass-api.de instead of a single hostname like z.overpass-api.de (which may go away in the near future as well!)
    – mmd
    Commented Mar 28, 2023 at 19:44
  • Yes, did this and updated to QuickOSM 2.2.1. Everything working that way! Thanks!
    – davidki
    Commented Mar 30, 2023 at 8:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.