6

Fairly new to QGIS, but making headway. Been successfully using QuickOSM to extract ski area features on Topo maps. But as of yesterday, 0 queries have gone through. Same error; Download failed: Connection timed out.

Researched and tried changing timeout under advanced tab to no effect. Tried 5 different networks, and 2 PCs now. Same Issue, I'm at a loss.

How can I fix this?

2
  • Please upgrade to the latest version 2.2.1 of QuickOSM, the list of Overpass server has been updated.
    – etrimaille
    Commented Mar 29, 2023 at 8:59
  • 1
    Please add the error message as text, not picture. Commented Apr 2, 2023 at 16:56

2 Answers 2

12

First : Please upgrade to the latest version available (2.2.1 today) of QuickOSM in your QGIS plugin manager, the list of Overpass servers has been updated recently.

The default server used before this new release is not the correct one anymore. This latest release changes the default server which was used. It's now using https://overpass-api.de/api/ by default.

Maybe you have changed your preferred server before the update, QuickOSM will still use your previous choice and will not reset your custom choice. So check in your QuickOSM window then "Parameters" that you are not using a custom overpass server. Click "Save".

Then, if it's not enough:

You should have a look to your timeout set in QuickOSM :

QuickOSM timeout

And also in QGIS settings :

QGIS timeout

1
  • That was it. API changed, full functionality. Thank you so much.
    – G4CW
    Commented Apr 2, 2023 at 16:43
3

The Overpass Turbo site is an alternative option to QuickOSM. There is a wizard which was used to create the query below. There are a few different export formats. KML and GPX work for QGIS import.

enter image description here

Access the site from here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.