10

When merging two layers of polygons so that they produce a third layer where no polygon contains another polygon, I find that the product contains some very small polygons, almost too small to see.

enter image description here

Presumably, this is due to boundaries that are almost the same but have a very slight difference.

What could possibly be done to prevent this?

I was using the latest QGIS's Vector/Geospatial/Union option but would try any open-source tool.

Do you think this question has answers that might be the solution?

1

1 Answer 1

12

You can use the "Snap geometries to layer" tool by specifying the tolerance distance before "Union".

In the example, the green layer is snapped to the red layer so that the gap between the layers does not result in a small polygon.

enter image description here

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.