3

I am building a model using the Model Designer in QGIS and I have ran into a problem.

The model I have developed creates a grid of points, rotates this grid by a defined degree, clips the points to a defined boundary, then extracts the points based on defined exclusion zones using the difference algorithm. It then samples an input raster (bathymetry) using the points to obtain water depths at each of the points. This all works just as I would like so far, see screenshot of model and output:

Model Model Output

The last function I would like this model to perform is to extract the points by their water depth attribute to allow me to extract only the points that fall within an acceptable defined water depth range. See bathymetry raster for context:

Bathymetry

I can extract the desired points either by using the "Extract by Attribute" or "Extract by Expression" algorithms. See screenshots with example extracting points >=-30m water depth:

Extract by Attribute Extract by Expression Extract Output

This works perfectly when I do this manually. My problem is that when I try to use the exact same algorithms in the model, the "Water Depth (m)" field can not be found. For both algorithm approaches, the only attribute/field that shows up is NULL.

No attributes showing Only showing NULL field

Can anyone help with why the Water Depth attribute is not showing up in the model, despite the previous algorithm sampling the raster? I hope this is clear enough, but I will reply or edit this post to address any questions.

3
  • 1
    Have you tried manually adding "Water Depth (m)">=-30 as an expression? Maybe it does not have to be added using Fields and Values
    – Bera
    Commented Apr 12, 2023 at 17:20
  • 1
    Thank you BERA, that worked. I also realised that I was typing "Water Depth (m)" (which is what I set the field to be named), but for some reason the field has been named "Water Depth (m)1". When I use that expression it works perfectly. Commented Apr 13, 2023 at 13:10
  • Nice I'll add that as an answer
    – Bera
    Commented Apr 13, 2023 at 13:20

1 Answer 1

1

Try adding "Water Depth (m)">=-30 manually as an expression.

It does not have to be added using Fields and Values.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.