1

Not having luck with the "Save Raster Layer As..." dialogue, so tried to create the simplest possible file to pin down what I am doing wrong.

I opened a new project and simply added the built-in Mapzen Global Terrain. Next, right clicked the layer and selected Export > Save As, with the canvas centered in Australia, since I'm trying to capture grayscale heightmaps of countries to use in Blender.

enter image description here

Output mode is rendered image, and the format is GeoTIFF. CRS is EPSG:3857-WGS 84/Pseudo-Mercator. I then clicked the Map Canvas Extent button, which changes the coordinates on Extent - seems quicker than manually clipping the layer with a polygon shape. Unchecked Create VRT. On most video tutorials, the buttons on Resolution are active, whereas on my interface they are grayed out, no idea why. I assume the inputs after Horizontal are a fraction of the layer resolution.

Some indication as to what it is would help new users like me, since I found nothing searching the documentation. Also, what are the units for the Columns field?

Trying a value of 1 for fields on Horizontal yields me one of these two errors:

enter image description here enter image description here

Upon trying a value of 0.01 for horizontal and vertical, I get the following error:

enter image description here

Trying 0.001 instead, I get the following:

enter image description here

2
  • @user2856 It worked at 1000 for horizontal and vertical inputs. Are they meters per pixel, then? Columns and Rows match with the output image's resolution. Wish there were hints in the interface about this, would have saved me a lot of time. Apr 19, 2023 at 1:58
  • 1
    I guess it's one of those "assumed knowledge" things. If you're used to working with raster data, you'll just know that resolution is the size of a pixel (think length of the sides of a rectangle) in the units (metres, feet, decimal degrees etc.) of the coordinate system that the raster is in. But if you're new at this game it can be hard to find these things out.
    – user2856
    Apr 19, 2023 at 6:07

1 Answer 1

1

The units are as per the CRS, i.e. metres.

A 0.01 m (1 cm) resolution raster over continental Australia is going to be huuuuge, just have a look at the number of output columns and rows.

Suggest you change to resolution to 100m (or 1000m just to test).

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.