1

I work on a Debian 11 virtual server, apache and qgis server are installed and working. I also installed the "qgis-lizmap-server-plugin" plugin and the "qgis plugin manager". I 'm trying now to install lizmap web client thanks to the official doc. https://docs.lizmap.com/3.6/fr/install/linux.html I have a question regarding the Web Configuration section. I installed the necessary packages: curl, openssl, libssl1.1, nginx-full, nginx nginx-common, php7.4-fpm php7.4-cli php7.4-bz2 php7.4-curl php7.4-gd php7.4-intl php7.4-json php7.4-mbstring php7.4-pgsql php7.4-sqlite3 php7.4-xml php7.4-ldap php7.4-redis.

As requested by the doc, I created a lizmap.conf file under /etc/apache2/sites-available/ I replaced in this file the value localhost by the name of the server XXX.XXXX.fr This is the only modification made in this file. It is written in the doc:

"You should declare the lizmap.local domain name somewhere (in your /etc/hosts, or into your DNS..), or replace it by your own domain name."

I did not declare a lizmap.local domain under /etc/hosts. Is it mandatory? Or is it optional? Because i have already done a similar action for qgis server installation. Can someone explain this step? Are there any examples showing how to do this?

I tried anyway to activate the virtual host :

"ln -s /etc/apache2/sites-available/lizmap.conf /etc/apache2/sites-enabled/lizmap.conf"

But when I try to restart apache, I can't. With these error messages:

root@XXXXXXXXXXXX:/etc/apache2/sites-enabled# systemctl status apache2
● apache2.service - The Apache HTTP Server
     Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Mon 2023-04-24 15:21:31 CEST; 1min 32s ago
       Docs: https://httpd.apache.org/docs/2.4/
    Process: 657246 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)
        CPU: 30ms

avril 24 15:21:31 XXXXXXXXXXXX systemd[1]: Starting The Apache HTTP Server...
avril 24 15:21:31 XXXXXXXXXXXX apachectl[657249]: apache2: Syntax error on line 240 of /etc/apache2/apache2.conf: Syntax error on line 24 of /etc/apache2/sites-enabled/lizmap.conf: Could not open configuration file /etc/apache2/fastc>
avril 24 15:21:31 XXXXXXXXXXXX apachectl[657246]: Action 'start' failed.
avril 24 15:21:31 XXXXXXXXXXXX apachectl[657246]: The Apache error log may have more information.
avril 24 15:21:31 XXXXXXXXXXXX systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
avril 24 15:21:31 XXXXXXXXXXXX systemd[1]: apache2.service: Failed with result 'exit-code'.
avril 24 15:21:31 XXXXXXXXXXXX systemd[1]: Failed to start The Apache HTTP Server.
 ESCOC
yntax error on line 24 of /etc/apache2/sites-enabled/lizmap.conf: Could not open configuration file /etc/apache2/fastcgi_params;: No such file or directory

The error message seems to refer to line 24 of the lizmap.conf file. This line is:

include fastcgi_params;
1

2 Answers 2

0

Following to my previous post, For information, I limited myself to read the page https://docs.lizmap.com/3.6/fr/install/linux.html I did not look at the pages https://docs.lizmap.com/3.6/fr/install/configuration.html and https://docs.lizmap.com/3.6/fr/install/advanced_install.html I confirm that the URL http://XXXX.XXXX.fr/cgi-bin/qgis_mapser… MAP= does NOT return any error. I therefore did not define a host for lizmap since I had already done one for qgis server. I created folders for the data. I created a postgis database on a posgresql server hosted on another server. I have created the profiles.ini.php files I edited the file like this:

[jdb:jauth]
driver=pgsql
host=IP of the server
port=5432
database="XXXXXX"
user=XXXXX
password=XXXXXX
search_path=public
sslmode=disable

[jdb:lizlog]
driver=pgsql
host=IP of the server
port=5432
database="XXXXXX"
user=XXXXXX
password=XXXXXX
search_path=public
sslmode=disable

I have successfully installed the lizmap web client sources.

the url

http://XXXXXXXXX/lizmap/index.php/view/app/metadata

returns me Not Found The requested URL was not found on this server. Apache/2.4.54 (Debian) Server at XXXX.XXXX.fr Port 80

the URL

http://XXXX.XXXX.fr/lizmap/

returns

<?php
/**
* @lizmap package
* @subpackage lizmap
* @author 3liz
* @copyright 2011 3liz
* @link http://3liz.com
* @license Mozilla Public License: http://www.mozilla.org/MPL/
*/
require('../application.init.php');
require (JELIX_LIB_CORE_PATH.'request/jClassicRequest.class.php');
checkAppOpened();
// Load the configuration
jApp::loadConfig('index/config.ini.php');
// new coordinator, which we indicate to jApp
jApp::setCoord(new jCoordinator());
// New request object, which we pass to the coordinator, to process the routing.
jApp::coord()->process(new jClassicRequest());

Weird... it returns the PHP code and it must be missing the end of the code (it starts with ) maybe there is a config to do in Apache to tell it to run the PHP code instead of returning it in text format...? In the lizmapCOnfig.ini.php file, I only replaced the default IP 127.0.0.1 with the name of our server at the line wmsServerURL="http://127.0.0.1/cgi-bin/qgis_mapserver.fcgi"

When I ran php configurator.php I got no error message. When I ran php installer.php:

Installation is starting
All modules dependencies are ok
Installation starts
Module jelix installed
[error] An error occured during the installation of the module jcommunity: error during the connection XXXXIP of the server host postgresql

Installation is finished

I have successfully installed the demo. But these URLs return me a Not Found The requested URL was not found on this server. Apache/2.4.54 (Debian) Server at XXXXX.XXXX.fr Port 80:

http://xxxxx/lizmap/index.php/lizmap/service/?repository=montpellier&project=montpellier&VERSION=1.3.0&SERVICE=WMS&REQUEST=GetCapabilities

http://xxxxxx/lizmap/index.php/lizmap/service/?repository=montpellier&project=montpellier&SERVICE=WFS&REQUEST=GetCapabilities

0

It's it works now. I had to set mod_php. And there was indeed a typo in my BDD postgresql settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.