1

After merging SRTM DEM tiles into 1 raster layer, the layer has no visible join lines on the map canvas as below. Multiply blending mode has been applied enter image description here

However, when viewed in Layout, there is a visible line as below enter image description here

This is not visible if normal blending mode is applied to the layer. I'm using QGIS 3.28.5


Well an not directly an answer, but solves the issue. The line isn't shown when exported as a png file.

4
  • Are your really merging the layers or are you not rather creating a virtual raster?
    – Babel
    May 26, 2023 at 15:15
  • Yes I had merged them. May 26, 2023 at 15:31
  • Can you describe a bit more in detail what exactly where the steps you undertook? Can you maybe share the input rasters?
    – Babel
    May 26, 2023 at 15:35
  • 1
    After closing and reopening QGIS it isn't happening now - very odd. May 26, 2023 at 15:57

1 Answer 1

2

Such lines appear where two tiles overlap: 1 pixel width. It appears when you set the layers blending mode to Multiply, see screenshot.

When you either merge the rasters or create a virtual raster, the line should not appear. Creating a virtual raster is the easiest way as no real merging takes place - the rasters are just combined in a way as if they were merged.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.