I want to download OSM data from a query in an extent via the Graphical Modeler in QGIS. Thereby I want to download multiple keys and values at once, but it somehow only takes the first one or none.

Let's take the example of primary, secondary and tertiary streets.

enter image description here

The modeler states that multiple keys can be asked by adding the seperator ',' in between each key and value. I tried several versions with spaces an without, but it only downloads the first key and value pair or none.

Outside the modeler I can add multiple keys and values with Or and it works within QuickOSM. enter image description here

Any idea how I can replicate that inside the model builder without having three individual downloads? Thanks!

  • Can you tell us a little bit more about the workflow? Which algorithm do you use in the modeler - the one called Donwload OSM data from a query in an extent in your screenshot? Where do you see the information that the modeler states that multiple keys can be asked by adding the seperator
    – Babel
    Jun 3 at 13:00
  • Can you share your model? I also can't see how you get the output (Streets) - fragmentary information about you workflow makes it more difficult to address your problem. I don't have the option Output file: i.stack.imgur.com/VpjN0.png
    – Babel
    Jun 3 at 13:08
  • @Lucas_Edenhofer can you please tell us how you were able to use Download OSM data from a query in the Model Designer. This algorithm does not appear in the algorithm list
    – user231744
    Dec 6 at 22:26

1 Answer 1


Use semicolon ; to delimit the different values, which are enclose in single quotes '. Don't repeat the key if it is the same for all values.

Then try using either

  1. With the default Value setting and the string 'primary';'secondary';'tertiary'


  2. with setting Pre-calculated Value and the string eval ('"primary" or "secondary" or "tertiary"')

enter image description here

  • 1
    Second option with worked. Jun 5 at 12:32
  • Hi @Lucas_Edenhofer, I'm trying to do the same thing but can't get it to work. Please can you post your model or some screenshots?
    – Aquamarine
    Jun 8 at 8:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.