1

I am trying to clone the default, active arcgispro-py3 environment using the Package Manager tab in ArcGIS Pro 3.1. I have not yet cloned any environments on this installation.

The Create Environment task works for awhile, but eventually it errors out without creating the clone of arcgispro-py3.

What can I do to fix this issue?

1 Answer 1

1

The first thing you may want to check is to ensure that the default arcgispro-py3 environment isn't corrupt. See Installing Packages in a cloned environment in ArcGIS Pro 3.1 Throws an Error. If you continue to experience trouble cloning the default arcgispro-py3 environment, a fix may lie in the computer's registry.

As covered under Known Issues in Deep Learning Libraries Installers for ArcGIS, package paths may exceed the Windows MAX_PATH limitation when attempting to create cloned environments. The way around this is to update the LongPathsEnabled value in your registry from 0 to 1.

You should be able to find the LongPathsEnabled value in Regedit at Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem

As a disclaimer, you should always exercise extreme caution when using Regedit as making improper changes can corrupt your Windows installation. If you are uncomfortable working with registry keys, seek assistance from someone with more experience.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.